summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 0d2ba9f6..c2bd4a4a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -408,6 +408,7 @@ builtin_modules += sim900
builtin_sources += plugins/sim900.c
if BLUETOOTH
+if BLUEZ4
builtin_modules += bluetooth
builtin_sources += plugins/bluetooth.c plugins/bluetooth.h
@@ -434,6 +435,7 @@ builtin_cflags += @BLUEZ_CFLAGS@
builtin_libadd += @BLUEZ_LIBS@
endif
endif
+endif
if PROVISION
builtin_sources += plugins/mbpi.h plugins/mbpi.c
@@ -742,6 +744,8 @@ tools_stktest_LDADD = @GLIB_LIBS@ @DBUS_LIBS@
endif
endif
+if BLUETOOTH
+if BLUEZ4
if DUNDEE
sbin_PROGRAMS += dundee/dundee
@@ -759,7 +763,8 @@ if SYSTEMD
systemdunit_DATA += dundee/dundee.service
endif
endif
-
+endif
+endif
endif
noinst_PROGRAMS += gatchat/gsmdial gatchat/test-server gatchat/test-qcdm