summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorClaudio Takahasi <claudio.takahasi@openbossa.org>2013-01-16 10:31:26 -0300
committerDenis Kenzior <denkenz@gmail.com>2013-01-16 13:34:22 -0600
commit145112dad26f79c8d8eaa9f0f1411a49b6fb7001 (patch)
tree58df45f7a700870ed470becd3f693cb6067c0717 /Makefile.am
parentb67e68e75318f186bb97c8d14ca553725613e2f8 (diff)
downloadofono-145112dad26f79c8d8eaa9f0f1411a49b6fb7001.tar.bz2
build: Add configure option for BlueZ 5 support
Going forward, BlueZ 5 will be supported by default. BlueZ 4 support will have to be explicitly enabled by using '--enable-bluez4'. As before, the '--disable-bluetooth' configure option will disable all bluetooth support (BlueZ 4 and BlueZ 5)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 0d2ba9f6..c2bd4a4a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -408,6 +408,7 @@ builtin_modules += sim900
builtin_sources += plugins/sim900.c
if BLUETOOTH
+if BLUEZ4
builtin_modules += bluetooth
builtin_sources += plugins/bluetooth.c plugins/bluetooth.h
@@ -434,6 +435,7 @@ builtin_cflags += @BLUEZ_CFLAGS@
builtin_libadd += @BLUEZ_LIBS@
endif
endif
+endif
if PROVISION
builtin_sources += plugins/mbpi.h plugins/mbpi.c
@@ -742,6 +744,8 @@ tools_stktest_LDADD = @GLIB_LIBS@ @DBUS_LIBS@
endif
endif
+if BLUETOOTH
+if BLUEZ4
if DUNDEE
sbin_PROGRAMS += dundee/dundee
@@ -759,7 +763,8 @@ if SYSTEMD
systemdunit_DATA += dundee/dundee.service
endif
endif
-
+endif
+endif
endif
noinst_PROGRAMS += gatchat/gsmdial gatchat/test-server gatchat/test-qcdm