summaryrefslogtreecommitdiffstats
path: root/debian/shopsystem.config
diff options
context:
space:
mode:
authorHolger Cremer <HolgerCremer@gmail.com>2018-08-27 19:38:11 +0200
committerHolger Cremer <HolgerCremer@gmail.com>2018-08-27 19:38:11 +0200
commit8f2ba2050ee78d0e4a47f1277c6bc4422d06170c (patch)
treec008d2878905e03df7a8bf8bd3330762cc2d8f43 /debian/shopsystem.config
parentbb55e121576a5b5d225bfc68c5062f386cc32db9 (diff)
parent3fc3ea6c6df237dbdf48d14703118b747bf5d647 (diff)
downloadserial-barcode-scanner-8f2ba2050ee78d0e4a47f1277c6bc4422d06170c.tar.bz2
Merge branch 'master' into better_inventory
Conflicts: README data/templates/products/entry.html docker/Dockerfile docker/init.sh src/database/database.vala src/database/db-interface.vala src/pdf-stock/Makefile src/pdf-stock/pdf-stock-interface.vala src/pdf-stock/pdf-stock.vala src/web/Makefile src/web/main.vala templates/menu.html templates/products/index.html
Diffstat (limited to 'debian/shopsystem.config')
-rw-r--r--debian/shopsystem.config16
1 files changed, 16 insertions, 0 deletions
diff --git a/debian/shopsystem.config b/debian/shopsystem.config
new file mode 100644
index 0000000..53aeb36
--- /dev/null
+++ b/debian/shopsystem.config
@@ -0,0 +1,16 @@
+#!/bin/sh
+set -e
+
+if [ -f /usr/share/debconf/confmodule ]; then
+ . /usr/share/debconf/confmodule
+fi
+
+if [ -f /usr/share/dbconfig-common/dpkg/config ]; then
+ dbc_dbtypes="sqlite3"
+ dbc_basepath="/var/lib/shopsystem"
+ dbc_dbname="shopsystem.db"
+ . /usr/share/dbconfig-common/dpkg/config
+ dbc_go shopsystem $@
+fi
+
+exit 0