summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorSebastian Reichel <sre@ring0.de>2018-07-14 19:33:03 +0200
committerSebastian Reichel <sre@ring0.de>2018-07-18 01:27:02 +0200
commitf77ef3ceb3b828724a60c4838b3524e8f7c5115b (patch)
treeebbf42206415464a39d77234263c4ea128524056 /debian/rules
parent568c2be3c328a272f7a872c3fc67b61af3c4e797 (diff)
downloadserial-barcode-scanner-f77ef3ceb3b828724a60c4838b3524e8f7c5115b.tar.bz2
Debian packaging
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules13
1 files changed, 13 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..ac0c346
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,13 @@
+#!/usr/bin/make -f
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+DPKG_EXPORT_BUILDFLAGS = 1
+include /usr/share/dpkg/buildflags.mk
+
+%:
+ dh $@ --buildsystem=meson --with=sysuser
+
+override_dh_install:
+ dh_install
+ mkdir -p debian/shopsystem/usr/share/dbconfig-common/data/shopsystem/install
+ cat data/sql/tables.sql data/sql/trigger.sql data/sql/views.sql > debian/shopsystem/usr/share/dbconfig-common/data/shopsystem/install/sqlite3
+ find debian/shopsystem/usr/share/shopsystem/sounds -name LICENSE -exec rm {} \;