summaryrefslogtreecommitdiffstats
path: root/data/systemd/meson.build
diff options
context:
space:
mode:
authorHolger Cremer <HolgerCremer@gmail.com>2018-08-27 19:38:11 +0200
committerHolger Cremer <HolgerCremer@gmail.com>2018-08-27 19:38:11 +0200
commit8f2ba2050ee78d0e4a47f1277c6bc4422d06170c (patch)
treec008d2878905e03df7a8bf8bd3330762cc2d8f43 /data/systemd/meson.build
parentbb55e121576a5b5d225bfc68c5062f386cc32db9 (diff)
parent3fc3ea6c6df237dbdf48d14703118b747bf5d647 (diff)
downloadserial-barcode-scanner-8f2ba2050ee78d0e4a47f1277c6bc4422d06170c.tar.bz2
Merge branch 'master' into better_inventory
Conflicts: README data/templates/products/entry.html docker/Dockerfile docker/init.sh src/database/database.vala src/database/db-interface.vala src/pdf-stock/Makefile src/pdf-stock/pdf-stock-interface.vala src/pdf-stock/pdf-stock.vala src/web/Makefile src/web/main.vala templates/menu.html templates/products/index.html
Diffstat (limited to 'data/systemd/meson.build')
-rw-r--r--data/systemd/meson.build18
1 files changed, 18 insertions, 0 deletions
diff --git a/data/systemd/meson.build b/data/systemd/meson.build
new file mode 100644
index 0000000..a4f9508
--- /dev/null
+++ b/data/systemd/meson.build
@@ -0,0 +1,18 @@
+systemd = dependency('systemd')
+systemdsystemunitdir = systemd.get_pkgconfig_variable('systemdsystemunitdir')
+bindir = join_paths(get_option('prefix'), get_option('libexecdir'), 'shopsystem')
+
+cfg = configuration_data()
+cfg.set('PATH', bindir)
+
+install_data('shopsystem-mail-daily-invoice.timer', install_dir: systemdsystemunitdir)
+install_data('shopsystem-mail-monthly-invoice.timer', install_dir: systemdsystemunitdir)
+install_data('shopsystem-mail-backup.timer', install_dir: systemdsystemunitdir)
+
+configure_file(input: 'shopsystem-input-device.service.in', output: 'shopsystem-input-device.service', configuration: cfg, install_dir: systemdsystemunitdir)
+configure_file(input: 'shopsystem-mail-backup.service.in', output: 'shopsystem-mail-backup.service', configuration: cfg, install_dir: systemdsystemunitdir)
+configure_file(input: 'shopsystem-mail-daily-invoice.service.in', output: 'shopsystem-mail-daily-invoice.service', configuration: cfg, install_dir: systemdsystemunitdir)
+configure_file(input: 'shopsystem-mail-monthly-invoice.service.in', output: 'shopsystem-mail-monthly-invoice.service', configuration: cfg, install_dir: systemdsystemunitdir)
+configure_file(input: 'shopsystem-ui.service.in', output: 'shopsystem-ui.service', configuration: cfg, install_dir: systemdsystemunitdir)
+configure_file(input: 'shopsystem-web.service.in', output: 'shopsystem-web.service', configuration: cfg, install_dir: systemdsystemunitdir)
+configure_file(input: 'shopsystem-display-on-off.service.in', output: 'shopsystem-display-on-off.service', configuration: cfg, install_dir: systemdsystemunitdir)