summaryrefslogtreecommitdiffstats
path: root/data/systemd/meson.build
diff options
context:
space:
mode:
authorSebastian Reichel <sre@ring0.de>2018-06-29 00:58:19 +0200
committerSebastian Reichel <sre@ring0.de>2018-07-15 22:59:57 +0200
commit22df08c29f6e4566d418e2a80a8279303406a733 (patch)
treedecb3029284b966635855e1684bc07ef9d3c1a6f /data/systemd/meson.build
parent17560f8bf49a0be2e0b490159e29f4894fe12cba (diff)
downloadserial-barcode-scanner-22df08c29f6e4566d418e2a80a8279303406a733.tar.bz2
build: switch to meson buildsystem
We build the project with 'meson' now instead of using custom configure script + GNU Makefiles. To build the project, go to the project root directory and use the following commands: Building: meson build cd build ninja Update Language Files: ninja shopsystem-pot ninja shopsystem-update-po Install: DESTDIR=./tmp ninja install
Diffstat (limited to 'data/systemd/meson.build')
-rw-r--r--data/systemd/meson.build18
1 files changed, 18 insertions, 0 deletions
diff --git a/data/systemd/meson.build b/data/systemd/meson.build
new file mode 100644
index 0000000..cd68b1b
--- /dev/null
+++ b/data/systemd/meson.build
@@ -0,0 +1,18 @@
+systemd = dependency('systemd')
+systemdsystemunitdir = systemd.get_pkgconfig_variable('systemdsystemunitdir')
+bindir = join_paths(get_option('prefix'), get_option('bindir'))
+
+cfg = configuration_data()
+cfg.set('PATH', bindir)
+
+install_data('shopsystem-mail-daily-invoice.timer', install_dir: systemdsystemunitdir)
+install_data('shopsystem-mail-monthly-invoice.timer', install_dir: systemdsystemunitdir)
+install_data('shopsystem-mail-backup.timer', install_dir: systemdsystemunitdir)
+
+configure_file(input: 'shopsystem-input-device.service.in', output: 'shopsystem-input-device.service', configuration: cfg, install_dir: systemdsystemunitdir)
+configure_file(input: 'shopsystem-mail-backup.service.in', output: 'shopsystem-mail-backup.service', configuration: cfg, install_dir: systemdsystemunitdir)
+configure_file(input: 'shopsystem-mail-daily-invoice.service.in', output: 'shopsystem-mail-daily-invoice.service', configuration: cfg, install_dir: systemdsystemunitdir)
+configure_file(input: 'shopsystem-mail-monthly-invoice.service.in', output: 'shopsystem-mail-monthly-invoice.service', configuration: cfg, install_dir: systemdsystemunitdir)
+configure_file(input: 'shopsystem-ui.service.in', output: 'shopsystem-ui.service', configuration: cfg, install_dir: systemdsystemunitdir)
+configure_file(input: 'shopsystem-web.service.in', output: 'shopsystem-web.service', configuration: cfg, install_dir: systemdsystemunitdir)
+configure_file(input: 'shopsystem-display-on-off.service.in', output: 'shopsystem-display-on-off.service', configuration: cfg, install_dir: systemdsystemunitdir)