summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel.holtmann@intel.com>2009-04-26 20:51:36 +0200
committerMarcel Holtmann <marcel.holtmann@intel.com>2009-04-26 20:51:36 +0200
commit7851155b80c7276e301a247351522b87b3dd9373 (patch)
treef9d1b0dbbd07109b5ee7f9c04170fdb9dbf5d440 /configure.ac
parent798111efd4d2af5101993f10f7df76cbcfaa24bb (diff)
downloadofono-7851155b80c7276e301a247351522b87b3dd9373.tar.bz2
Add D-Bus helper library for GLib integration
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 10 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 33543c5e..c93616f0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -16,6 +16,12 @@ AC_PROG_CC
AC_PROG_CC_PIE
AC_PROG_INSTALL
+m4_define([_LT_AC_TAGCONFIG], [])
+m4_ifdef([AC_LIBTOOL_TAGS], [AC_LIBTOOL_TAGS([])])
+
+AC_DISABLE_STATIC
+AC_PROG_LIBTOOL
+
AC_ARG_ENABLE(debug, AC_HELP_STRING([--enable-debug],
[enable compiling with debugging information]), [
if (test "${enableval}" = "yes" &&
@@ -64,4 +70,7 @@ else
fi
AC_SUBST(DBUS_DATADIR)
-AC_OUTPUT(Makefile)
+AC_SUBST([GDBUS_CFLAGS], ['$(DBUS_CFLAGS) -I$(top_srcdir)/gdbus'])
+AC_SUBST([GDBUS_LIBS], ['$(top_builddir)/gdbus/libgdbus.la $(DBUS_LIBS)'])
+
+AC_OUTPUT(Makefile gdbus/Makefile)