summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorClaudio Takahasi <claudio.takahasi@openbossa.org>2013-01-16 10:31:26 -0300
committerDenis Kenzior <denkenz@gmail.com>2013-01-16 13:34:22 -0600
commit145112dad26f79c8d8eaa9f0f1411a49b6fb7001 (patch)
tree58df45f7a700870ed470becd3f693cb6067c0717 /configure.ac
parentb67e68e75318f186bb97c8d14ca553725613e2f8 (diff)
downloadofono-145112dad26f79c8d8eaa9f0f1411a49b6fb7001.tar.bz2
build: Add configure option for BlueZ 5 support
Going forward, BlueZ 5 will be supported by default. BlueZ 4 support will have to be explicitly enabled by using '--enable-bluez4'. As before, the '--disable-bluetooth' configure option will disable all bluetooth support (BlueZ 4 and BlueZ 5)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 14 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 450352b1..7db41982 100644
--- a/configure.ac
+++ b/configure.ac
@@ -173,14 +173,22 @@ AC_ARG_ENABLE(qmimodem, AC_HELP_STRING([--disable-qmimodem],
AM_CONDITIONAL(QMIMODEM, test "${enable_qmimodem}" != "no")
AC_ARG_ENABLE(bluetooth, AC_HELP_STRING([--disable-bluetooth],
- [disable Bluetooth modem support]),
+ [disable BlueZ 4 and BlueZ 5 plugins support]),
[enable_bluetooth=${enableval}])
-if (test "${enable_bluetooth}" != "no"); then
- PKG_CHECK_MODULES(BLUEZ, bluez >= 4.99, dummy=yes,
- AC_MSG_ERROR(Bluetooth library >= 4.99 is required))
+
+AC_ARG_ENABLE(bluez4, AC_HELP_STRING([--enable-bluez4],
+ [enable BlueZ 4 plugins support prior to BlueZ 5]),
+ [enable_bluez4=${enableval}])
+
+if (test "${enable_bluez4}" = "yes"); then
+ PKG_CHECK_MODULES(BLUEZ, bluez >= 4.99 bluez < 5,
+ enable_bluez4=yes,
+ AC_MSG_ERROR(Bluetooth library >= 4.99 and < 5 is required))
+ AC_SUBST(BLUEZ_CFLAGS)
+ AC_SUBST(BLUEZ_LIBS)
fi
-AC_SUBST(BLUEZ_CFLAGS)
-AC_SUBST(BLUEZ_LIBS)
+
+AM_CONDITIONAL(BLUEZ4, test "${enable_bluetooth}" != "no" && test "${enable_bluez4}" = "yes")
AM_CONDITIONAL(BLUETOOTH, test "${enable_bluetooth}" != "no")
AC_ARG_WITH([provisiondb], AC_HELP_STRING([--with-provisiondb=FILE],