summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTony Espy <espy@canonical.com>2015-12-17 18:29:15 -0500
committerDenis Kenzior <denkenz@gmail.com>2015-12-18 09:53:55 -0600
commit0e02229ceb7d3a1ad2537678931dcd2a63285807 (patch)
treed7c2adef9046061a8750d311b39ab8b1e842fad0 /configure.ac
parentdd16d4d1b55c02059794cfa0d1bcdd9a62923a0d (diff)
downloadofono-0e02229ceb7d3a1ad2537678931dcd2a63285807.tar.bz2
build: add support for upower plugin
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b8d42c8d..f6253e58 100644
--- a/configure.ac
+++ b/configure.ac
@@ -213,6 +213,11 @@ if (test "${enable_provision}" != "no"); then
fi
AM_CONDITIONAL(PROVISION, test "${enable_provision}" != "no")
+AC_ARG_ENABLE(upower, AC_HELP_STRING([--disable-upower],
+ [disable UPower plugin]),
+ [enable_upower=${enableval}])
+AM_CONDITIONAL(UPOWER, test "${enable_power}" != "no")
+
AC_ARG_ENABLE(datafiles, AC_HELP_STRING([--disable-datafiles],
[do not install configuration and data files]),
[enable_datafiles=${enableval}])