summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2009-09-01 18:54:27 -0700
committerMarcel Holtmann <marcel@holtmann.org>2009-09-01 18:54:27 -0700
commitd8282ec589106639d272571adcb1f2eb1dc495e8 (patch)
treec8b266565cdb9b541e294f7423df9d5b5adeea83 /Makefile.am
parent82d0720f535fd315766217da2ee33aa663c50c31 (diff)
downloadofono-d8282ec589106639d272571adcb1f2eb1dc495e8.tar.bz2
Add first steps for a udev based modem detection plugin
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 7ee65360..aaa3e39f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -39,6 +39,13 @@ gatchat_sources = gatchat/gatchat.h gatchat/gatchat.c \
gatchat/gatsyntax.h gatchat/gatsyntax.c \
gatchat/ringbuffer.h gatchat/ringbuffer.c
+if UDEV
+builtin_modules += udev
+builtin_sources += plugins/udev.c
+builtin_cflags += @UDEV_CFLAGS@
+builtin_libadd += @UDEV_LIBS@
+endif
+
if ISIMODEM
builtin_modules += isimodem
builtin_sources += $(gisi_sources) drivers/isimodem/isi.h \