summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPaulo Borges <paulo.borges@openbossa.org>2013-03-20 19:26:31 -0300
committerDaniel Wagner <daniel.wagner@bmw-carit.de>2013-03-24 13:18:55 +0100
commitd26dab944c16eeb113f68e8cfd90071b353530e6 (patch)
treec19965c523e771f6cbe52d37340b7b439c0af3d9 /Makefile.am
parent63f92d60b50dde964a705d4ffa531d2ad928507c (diff)
downloadofono-d26dab944c16eeb113f68e8cfd90071b353530e6.tar.bz2
dundee: Start BlueZ 5 support
This patch adds the BlueZ 5 support file for dundee.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 10 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 48e6261d..35240986 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -759,14 +759,12 @@ endif
endif
if BLUETOOTH
-if BLUEZ4
if DUNDEE
sbin_PROGRAMS += dundee/dundee
-dundee_dundee_SOURCES = $(gdbus_sources) $(gatchat_sources) $(btio_sources) \
- src/log.c src/dbus.c plugins/bluez4.c \
- dundee/dundee.h dundee/main.c dundee/dbus.c \
- dundee/manager.c dundee/device.c dundee/bluez4.c
+dundee_common_sources = $(gdbus_sources) $(gatchat_sources) \
+ src/log.c src/dbus.c dundee/dundee.h dundee/main.c \
+ dundee/dbus.c dundee/manager.c dundee/device.c
dundee_dundee_LDADD = $(builtin_libadd) @GLIB_LIBS@ @DBUS_LIBS@ -ldl
@@ -777,6 +775,13 @@ if SYSTEMD
systemdunit_DATA += dundee/dundee.service
endif
endif
+
+if BLUEZ4
+dundee_dundee_SOURCES = $(dundee_common_sources) $(btio_sources) \
+ plugins/bluez4.c dundee/bluez4.c
+else
+dundee_dundee_SOURCES = $(dundee_common_sources) plugins/bluez5.c \
+ dundee/bluez5.c
endif
endif
endif