summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPekka Pessi <ppessi@hamsa.research.nokia.com>2010-09-16 17:56:17 +0300
committerAki Niemi <aki.niemi@nokia.com>2010-09-30 11:25:47 +0300
commit82894cf58f8ed1ab4935bd17bac9890b15e4569d (patch)
treecc384fd3869c5f8ce7feb455723e7ced59b1ecb4 /Makefile.am
parentce2ff831877ea15d3cd2529007b94a033e0314ae (diff)
downloadofono-82894cf58f8ed1ab4935bd17bac9890b15e4569d.tar.bz2
n900: modem driver plugin for Nokia N900
This patch adds a modem driver plugin for the Nokia N900 internal modem. It controls the modem using the appropriate GPIO lines and thus works without the Maemo userspace. This plugin can run natively on the N900 with either Maemo or Meego kernels. However, it conflicts with the Maemo userspace, for which isigen should be used instead.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 51225067..66fecf7d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -133,6 +133,9 @@ builtin_sources += $(gisi_sources) \
builtin_modules += isigen
builtin_sources += plugins/isigen.c
+builtin_modules += n900
+builtin_sources += plugins/n900.c plugins/nokia-gpio.h plugins/nokia-gpio.c
+
builtin_modules += usbpnmodem
builtin_sources += plugins/usbpnmodem.c
endif