summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorAndres Salomon <dilinger@collabora.co.uk>2009-08-25 16:04:48 -0400
committerMarcel Holtmann <marcel@holtmann.org>2009-09-02 16:07:36 -0700
commit7b9f0773fa0bee12b9fe3128ad424f14ece731f0 (patch)
tree4976c5a33e63598087f584037a945a74608c8552 /Makefile.am
parent76b6e52d400931dfa6b8970d7a5ce81c5997517c (diff)
downloadofono-7b9f0773fa0bee12b9fe3128ad424f14ece731f0.tar.bz2
G1: Add initial HTC G1 modem support
G1 plugin is based on generic_at, with a bunch of stuff dropped and simplified. We use AT+CFUN=1 for powering on rather than having a configurable init string. We also manually set the default state during init (the G1 appears to start in mode V0 by default). The device (/dev/smd0) is hardcoded.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 71b402b8..c5103d7d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -99,6 +99,9 @@ builtin_sources += plugins/generic_at.c
builtin_modules += mbm
builtin_sources += plugins/mbm.c
+
+builtin_modules += g1
+builtin_sources += plugins/g1.c
endif
if MAINTAINER_MODE