summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2012-01-12 05:58:05 +0100
committerMarcel Holtmann <marcel@holtmann.org>2012-01-12 06:02:16 +0100
commit6ada7d8bdc600f6fa236ffd12c03d3e3d74af6fe (patch)
tree380b3114417d875afa7fe111f312d759ede53da5 /Makefile.am
parentaba7731fdc200396d31a08add90e49be8dd75b05 (diff)
downloadofono-6ada7d8bdc600f6fa236ffd12c03d3e3d74af6fe.tar.bz2
huaweimodem: Add support for USSD 8-bit PDU mode
The Huawei devices support a special 8-bit PDU mode for USSD that is by default selected (AT^USSDMODE=1). It avoids the complicated logic for character set selection and conversion.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 6ef8549a..b4adb6f6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -189,6 +189,7 @@ builtin_modules += huaweimodem
builtin_sources += drivers/atmodem/atutil.h \
drivers/huaweimodem/huaweimodem.h \
drivers/huaweimodem/huaweimodem.c \
+ drivers/huaweimodem/ussd.c \
drivers/huaweimodem/voicecall.c \
drivers/huaweimodem/audio-settings.c \
drivers/huaweimodem/gprs-context.c \