summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPhilippe Nunes <philippe.nunes@linux.intel.com>2011-11-17 17:21:00 +0100
committerDenis Kenzior <denkenz@gmail.com>2011-11-16 04:00:37 -0600
commit0de7994d1cb921092e682dfef39f876a118f4e9c (patch)
tree61169c608e9fd96922ba102a6ca2e01f6a68e810 /Makefile.am
parentf454dea15bdb5b69c136f40405295258739f20fc (diff)
downloadofono-0de7994d1cb921092e682dfef39f876a118f4e9c.tar.bz2
tools: Add lookup-provider-name utility
This is a quick tool to look up CDMA network name based on the SID from the mobile-broadband-provider-info database.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index a28f7900..337aeb75 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -627,7 +627,8 @@ TESTS = $(unit_tests)
if TOOLS
noinst_PROGRAMS += tools/huawei-audio tools/auto-enable \
- tools/get-location tools/lookup-apn
+ tools/get-location tools/lookup-apn \
+ tools/lookup-provider-name
tools_huawei_audio_SOURCES = $(gdbus_sources) tools/huawei-audio.c
tools_huawei_audio_LDADD = @GLIB_LIBS@ @DBUS_LIBS@
@@ -640,6 +641,10 @@ tools_get_location_LDADD = @GLIB_LIBS@ @DBUS_LIBS@
tools_lookup_apn_SOURCES = plugins/mbpi.c plugins/mbpi.h tools/lookup-apn.c
tools_lookup_apn_LDADD = @GLIB_LIBS@
+
+tools_lookup_provider_name_SOURCES = plugins/mbpi.c plugins/mbpi.h \
+ tools/lookup-provider-name.c
+tools_lookup_provider_name_LDADD = @GLIB_LIBS@
endif
noinst_PROGRAMS += gatchat/gsmdial gatchat/test-server gatchat/test-qcdm