summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2011-01-09 11:04:58 -0800
committerMarcel Holtmann <marcel@holtmann.org>2011-01-09 11:04:58 -0800
commit0bcbcc8db6b040db0638468769b40c89d23ddcd7 (patch)
tree638f864db78c3ed645b6b3f0289eebf20e8b51e5 /Makefile.am
parentfe9bb02484ee38711dd9c1f6c8d2d4bf111cb1b7 (diff)
downloadofono-0bcbcc8db6b040db0638468769b40c89d23ddcd7.tar.bz2
build: Add configure option for building tools
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index eb160019..8ad01cde 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -350,7 +350,8 @@ else
build_plugindir = $(plugindir)
endif
-AM_CFLAGS = @DBUS_CFLAGS@ @GLIB_CFLAGS@ @CAPNG_CFLAGS@ $(builtin_cflags) \
+AM_CFLAGS = @DBUS_CFLAGS@ @GLIB_CFLAGS@ @CAPNG_CFLAGS@ @USB_CFLAGS@ \
+ $(builtin_cflags) \
-DOFONO_PLUGIN_BUILTIN \
-DPLUGINDIR=\""$(build_plugindir)"\"
@@ -498,6 +499,7 @@ unit_test_caif_SOURCES = unit/test-caif.c $(gatchat_sources) \
unit_test_caif_LDADD = @GLIB_LIBS@
unit_objects += $(unit_test_caif_OBJECTS)
+if TOOLS
noinst_PROGRAMS += tools/huawei-audio tools/auto-enable
tools_huawei_audio_SOURCES = $(gdbus_sources) tools/huawei-audio.c
@@ -505,6 +507,7 @@ tools_huawei_audio_LDADD = @GLIB_LIBS@ @DBUS_LIBS@
tools_auto_enable_SOURCES = $(gdbus_sources) tools/auto-enable.c
tools_auto_enable_LDADD = @GLIB_LIBS@ @DBUS_LIBS@
+endif
noinst_PROGRAMS += gatchat/gsmdial gatchat/test-server gatchat/test-qcdm