summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorZhenhua Zhang <zhenhua.zhang@intel.com>2011-01-12 18:15:45 +0100
committerDenis Kenzior <denkenz@gmail.com>2011-01-13 17:14:55 -0600
commit2565d8aed68b200a988d7a3ae6f260c682de989a (patch)
treeb73f37f2d70bacda0b4f76f8a61db61441e7f883 /configure.ac
parente0e734619fec2e02facb3467ada16e8a6cf87cda (diff)
downloadofono-2565d8aed68b200a988d7a3ae6f260c682de989a.tar.bz2
bluetooth: Add Btio library for DUN
Btio library is the low level socket API for BT RFCOMM connection. We share the same library among BlueZ, Obex and oFono. So make sure you synchronize to other two projects when you make changes to btio.[ch].
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7a2ca790..2a650b10 100644
--- a/configure.ac
+++ b/configure.ac
@@ -102,6 +102,11 @@ else
fi
AC_SUBST(DBUS_CONFDIR)
+PKG_CHECK_MODULES(BLUEZ, bluez, dummy=yes,
+ AC_MSG_ERROR(libbluetooth is required))
+AC_SUBST(BLUEZ_CFLAGS)
+AC_SUBST(BLUEZ_LIBS)
+
AC_ARG_WITH(dbusdatadir, AC_HELP_STRING([--with-dbusdatadir=PATH],
[path to D-Bus data directory]), [path_dbusdata=${withval}],
[path_dbusdata="`$PKG_CONFIG --variable=datadir dbus-1`"])