summaryrefslogtreecommitdiffstats
path: root/data/po/meson.build
diff options
context:
space:
mode:
authorSebastian Reichel <sre@ring0.de>2018-06-29 00:58:19 +0200
committerSebastian Reichel <sre@ring0.de>2018-07-15 22:59:57 +0200
commit22df08c29f6e4566d418e2a80a8279303406a733 (patch)
treedecb3029284b966635855e1684bc07ef9d3c1a6f /data/po/meson.build
parent17560f8bf49a0be2e0b490159e29f4894fe12cba (diff)
downloadserial-barcode-scanner-22df08c29f6e4566d418e2a80a8279303406a733.tar.bz2
build: switch to meson buildsystem
We build the project with 'meson' now instead of using custom configure script + GNU Makefiles. To build the project, go to the project root directory and use the following commands: Building: meson build cd build ninja Update Language Files: ninja shopsystem-pot ninja shopsystem-update-po Install: DESTDIR=./tmp ninja install
Diffstat (limited to 'data/po/meson.build')
-rw-r--r--data/po/meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/data/po/meson.build b/data/po/meson.build
new file mode 100644
index 0000000..387ab1d
--- /dev/null
+++ b/data/po/meson.build
@@ -0,0 +1,2 @@
+i18n = import('i18n')
+i18n.gettext(meson.project_name(), args: ['--directory='+join_paths(meson.source_root(), 'src'), '--language=vala', '--from-code=utf-8', '--keyword=_', '--escape', '--sort-output'])