summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 11 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 6ecf76ed..196b2edc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -153,16 +153,22 @@ AC_SUBST(UDEV_CFLAGS)
AC_SUBST(UDEV_LIBS)
AM_CONDITIONAL(UDEV, test "${enable_udev}" = "yes")
-AC_ARG_ENABLE(isimodem, AC_HELP_STRING([--disable-isimodem],
- [disable PhoNet/ISI modem support]),
- [enable_isimodem=${enableval}])
-AM_CONDITIONAL(ISIMODEM, test "${enable_isimodem}" != "no")
-
AC_ARG_ENABLE(atmodem, AC_HELP_STRING([--disable-atmodem],
[disable ETSI AT modem support]),
[enable_atmodem=${enableval}])
AM_CONDITIONAL(ATMODEM, test "${enable_atmodem}" != "no")
+AC_ARG_ENABLE(phonesim, AC_HELP_STRING([--disable-phonesim],
+ [disable Phone simulator support]),
+ [enable_phonesim=${enableval}])
+AM_CONDITIONAL(PHONESIM, test "${enable_phonesim}" != "no" &&
+ test "${enable_atmodem}" != "no")
+
+AC_ARG_ENABLE(isimodem, AC_HELP_STRING([--disable-isimodem],
+ [disable PhoNet/ISI modem support]),
+ [enable_isimodem=${enableval}])
+AM_CONDITIONAL(ISIMODEM, test "${enable_isimodem}" != "no")
+
AC_ARG_ENABLE(datafiles, AC_HELP_STRING([--disable-datafiles],
[don't install configuration and data files]),
[enable_datafiles=${enableval}])